| Package | Affected versions | Patched versions |
|---|---|---|
| lxd | ≥ 4.12, < 5.0.6≥ 5.21.0, < 5.21.4≥ 6.0, < 6.7 | 5.0.65.21.46.7 |
An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free