| Package | Affected versions | Patched versions |
|---|
| craftcms/commerce Packagist | ≥ 4.0.0, < 4.10.2≥ 5.0.0, < 5.5.3
| 4.10.25.5.3
|
| craft commerce | ≥ 4.0.0, < 4.10.2≥ 5.0.0, < 5.5.3
| 4.10.25.5.3
|
Description
Summary
A stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur.
Proof of Concept
Required Permissions
- Admin access (to edit/create Order Statuses)
Steps to Reproduce
- Log in with an admin account
- Navigate to Commerce → Settings → Order Statuses
- Create a new order status
- Set the Name field to:
<img src=x onerror="alert('Order Statuses XSS')">
- Save the order status
- Go to Commerce → Orders (make sure you placed any orders)
- From the left panel, select any Order Status (e.g., New)
- Select any order from the orders table → Click on the Gear Icon → then click "Update Order Status..."
- Notice the XSS execution
NVD description
Craft Commerce is an ecommerce platform for Craft CMS. Prior to 4.10.2 and 5.5.3, a stored XSS vulnerability exists when a user tries to update the Order Status from the Commerce Orders Table. The Order Status Name is rendered without proper escaping, allowing script execution to occur. This vulnerability is fixed in 4.10.2 and 5.5.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free