In short
- CVE-2026-29612 is a HIGH (CVSS 7.5) vulnerability affecting openclaw (openclaw), clawdbot, openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 24.1% of all vulnerabilities.
- Fix: update to 2026.2.14 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.2.14
| 2026.2.14
|
| clawdbot npm | ≤ 2026.1.24-3
| No fix yet |
| openclaw npm | < 2026.2.14
| 2026.2.14
|
Description
Summary
Base64-backed media inputs could be decoded into Buffers before enforcing decoded-size budgets. An attacker supplying oversized base64 payloads can force large allocations, causing memory pressure and denial of service.
Attack Scenario Notes
- Recommended deployments bind the gateway to loopback by default and require gateway auth for HTTP endpoints. In that configuration, this is best modeled as a local/authorized DoS.
- If an operator exposes the gateway to untrusted networks (or disables/weakens auth and rate limits), treat this as a higher-severity network DoS risk.
Affected Packages / Versions
- openclaw (npm): <= 2026.2.13
- clawdbot (npm): <= 2026.1.24-3
Fixed In
- openclaw (npm): 2026.2.14 (planned)
- clawdbot (npm): no patched release planned; migrate to openclaw
Fix Commit(s)
- 31791233d60495725fa012745dde8d6ee69e9595
Credits
Thanks @vincentkoc for reporting.
NVD description
OpenClaw versions prior to 2026.2.14 decode base64-backed media inputs into buffers before enforcing decoded-size budget limits, allowing attackers to trigger large memory allocations. Remote attackers can supply oversized base64 payloads to cause memory pressure and denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free