In short
- CVE-2026-3108 is a HIGH (CVSS 8.8) vulnerability affecting github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5, github.com/mattermost/mattermost-server/v6.
- Chance of exploitation in the next 30 days (EPSS): 0.28%, higher than 20.9% of all vulnerabilities.
- Fix: update to 10.11.11+incompatible, 11.2.3+incompatible, 11.3.2+incompatible, 11.4.1+incompatible or later.
Description
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content in the mmctl commands terminal output which allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences that enable screen manipulation, fake prompts, and clipboard hijacking. Mattermost Advisory ID: MMSA-2026-00599.
NVD description
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to sanitize user-controlled post content in the mmctl commands terminal output which allows attackers to manipulate administrator terminals via crafted messages containing ANSI and OSC escape sequences that enable screen manipulation, fake prompts, and clipboard hijacking.. Mattermost Advisory ID: MMSA-2026-00599
More vulnerabilities in github.com/mattermost/mattermost-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free