In short
- CVE-2026-31800 is a CRITICAL (CVSS 9.1) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.35%, higher than 28.4% of all vulnerabilities.
- Fix: update to 9.5.2, 8.6.25, 9.5.2-alpha.12 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.25
| 9.5.28.6.25
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.5.2-alpha.12< 8.6.25
| 9.5.2-alpha.128.6.25
|
Description
Impact
The _GraphQLConfig and _Audience internal classes can be read, modified, and deleted via the generic /classes/_GraphQLConfig and /classes/_Audience REST API routes without master key authentication. This bypasses the master key enforcement that exists on the dedicated /graphql-config and /push_audiences endpoints. An attacker can read, modify and delete GraphQL configuration and push audience data.
Patches
The fix adds the affected internal classes to the classesWithMasterOnlyAccess list, ensuring that the generic /classes/ routes enforce master key access consistently with the dedicated endpoints.
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.12 and 8.6.25, the _GraphQLConfig and _Audience internal classes can be read, modified, and deleted via the generic /classes/_GraphQLConfig and /classes/_Audience REST API routes without master key authentication. This bypasses the master key enforcement that exists on the dedicated /graphql-config and /push_audiences endpoints. An attacker can read, modify and delete GraphQL configuration and push audience data. This vulnerability is fixed in 9.5.2-alpha.12 and 8.6.25.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free