In short
- CVE-2026-31828 is a HIGH (CVSS 8.8) vulnerability affecting parse-server (parseplatform), parse-server.
- Chance of exploitation in the next 30 days (EPSS): 0.45%, higher than 39.0% of all vulnerabilities.
- Fix: update to 9.5.2, 8.6.26, 9.5.2-alpha.13 or later.
| Package | Affected versions | Patched versions |
|---|
| parse-server | = 9.5.2≥ 9.0.0, < 9.5.2< 8.6.26
| 9.5.28.6.26
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.5.2-alpha.13< 8.6.26
| 9.5.2-alpha.138.6.26
|
Description
Impact
The LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group.
The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control.
Patches
The vulnerability is fixed by escaping user input before interpolation into DN strings (per RFC 4514) and LDAP filter strings (per RFC 4515).
Workarounds
There is no known workaround.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.13 and 8.6.26, the LDAP authentication adapter is vulnerable to LDAP injection. User-supplied input (authData.id) is interpolated directly into LDAP Distinguished Names (DN) and group search filters without escaping special characters. This allows an attacker with valid LDAP credentials to manipulate the bind DN structure and to bypass group membership checks. This enables privilege escalation from any authenticated LDAP user to a member of any restricted group. The vulnerability affects Parse Server deployments that use the LDAP authentication adapter with group-based access control. This vulnerability is fixed in 9.5.2-alpha.13 and 8.6.26.
More vulnerabilities in parse-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free