In short
- CVE-2026-31887 is a HIGH (CVSS 7.5) vulnerability affecting shopware/core, shopware/platform, shopware (shopware).
- Chance of exploitation in the next 30 days (EPSS): 0.25%, higher than 16.0% of all vulnerabilities.
- Fix: update to 6.7.8.1, 6.6.10.15 or later.
| Package | Affected versions | Patched versions |
|---|
| shopware/core Packagist | ≥ 6.7.0.0, < 6.7.8.1< 6.6.10.15
| 6.7.8.16.6.10.15
|
| shopware/platform Packagist | ≥ 6.7.0.0, < 6.7.8.1< 6.6.10.15
| 6.7.8.16.6.10.15
|
| shopware | ≥ 6.7.0.0, < 6.7.8.1< 6.6.10.15
| 6.7.8.16.6.10.15
|
Description
Summary
An insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint.
Details
Data Exposure
Depending on the order payload configuration, attackers may retrieve:
- Customer names
- Billing address
- Shipping address
- Email addresses
- Ordered products
- Order values
- Order numbers
- Order dates
- Payment method information
- Shipping method information
- More customs, depending on the given associations in the request
Security Impact
This vulnerability allows:
- Unauthorized access to foreign customer order data
- Mass enumeration of recent orders
- Potential scraping of customer personal information
Limitation
No limitation, but only orders from the past 30 days are checked for changeable means of payment (unrelated).
Impact
The code is present since ~2021. Likely every version since then is impacted for every store.
NVD description
Shopware is an open commerce platform. Prior to 6.7.8.1 and 6.6.10.15, an insufficient check on the filter types for unauthenticated customers allows access to orders of other customers. This is part of the deepLinkCode support on the store-api.order endpoint. This vulnerability is fixed in 6.7.8.1 and 6.6.10.15.
More vulnerabilities in shopware/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free