| Package | Affected versions | Patched versions |
|---|---|---|
| craftcms/cms | ≥ 4.0.0-RC1, < 4.17.5≥ 5.0.0-RC1, < 5.9.11 | 4.17.55.9.11 |
| craft cms | = 4.0.0= 5.0.0≥ 4.0.0.1, < 4.17.5≥ 5.0.1, < 5.9.11 | 4.17.55.9.11 |
The fix for https://github.com/advisories/GHSA-7jx7-3846-m7w7 (commit https://github.com/craftcms/cms/commit/395c64f0b80b507be1c862a2ec942eaacb353748) only patched src/services/Fields.php, but the same vulnerable pattern exists in ElementIndexesController and FieldsController.
You need Craft control panel administrator permissions, and allowAdminChanges must be enabled for this to work.
An attacker can use the same gadget chain from the original advisory to achieve RCE.
Users should update to Craft 4.17.5 and 5.9.11 to mitigate the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free