In short
- CVE-2026-3293 is a MEDIUM (CVSS 5.5) vulnerability affecting net.snowflake:snowflake-jdbc, snowflake jdbc (snowflake).
- Chance of exploitation in the next 30 days (EPSS): 0.26%, higher than 17.7% of all vulnerabilities.
- Fix: update to 4.0.1 or later.
Description
A weakness has been identified in Snowflake JDBC Driver up to 4.0.1. Impacted is the function SdkProxyRoutePlanner of the file src/main/java/net/snowflake/client/internal/core/SdkProxyRoutePlanner.java of the component JDBC URL Handler. Executing a manipulation of the argument nonProxyHosts can lead to inefficient regular expression complexity. The attack can only be executed locally. The exploit has been made available to the public and could be used for attacks. This patch is called 5fb0a8a318a2ed87f4022a1f56e742424ba94052. A patch should be applied to remediate this issue.
NVD description
A weakness has been identified in snowflakedb snowflake-jdbc up to 4.0.1. Impacted is the function SdkProxyRoutePlanner of the file src/main/java/net/snowflake/client/internal/core/SdkProxyRoutePlanner.java of the component JDBC URL Handler. Executing a manipulation of the argument nonProxyHosts can lead to inefficient regular expression complexity. The attack can only be executed locally. The exploit has been made available to the public and could be used for attacks. This patch is called 5fb0a8a318a2ed87f4022a1f56e742424ba94052. A patch should be applied to remediate this issue.
More vulnerabilities in net.snowflake:snowflake-jdbc
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free