In short
- CVE-2026-33218 is a HIGH (CVSS 7.5) vulnerability affecting github.com/nats-io/nats-server, github.com/nats-io/nats-server/v2, nats-server (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 0.63%, higher than 50.0% of all vulnerabilities.
- Fix: update to 2.12.6, 2.11.15 or later.
Description
Background
NATS.io is a high performance open source pub-sub distributed communication technology, built for the cloud, on-premise, IoT, and edge computing.
The nats-server allows hub/spoke topologies using "leafnode" connections by other nats-servers.
Problem Description
A client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication.
Affected Versions
Any version before v2.12.6 or v2.11.15
Workarounds
- Disable leafnode support if not needed.
- Restrict network connections to your leafnode port, if plausible without compromising the service offered.
References
NVD description
NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Prior to versions 2.11.15 and 2.12.6, a client which can connect to the leafnode port can crash the nats-server with a certain malformed message pre-authentication. Versions 2.11.15 and 2.12.6 contain a fix. As a workaround, disable leafnode support if not needed or restrict network connections to the leafnode port, if plausible without compromising the service offered.
More vulnerabilities in github.com/nats-io/nats-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free