In short
- CVE-2026-33220 is a MEDIUM (CVSS 6.8) vulnerability affecting weblate, weblate (weblate).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.4% of all vulnerabilities.
- Fix: update to 5.17 or later.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
The translation memory API exposed unintended endpoints, which in turn didn't do proper access control.
Patches
Workarounds
The CDN add-on is not enabled by default.
References
Thanks to @spbavarva for reporting this responsibly via GitHub.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, the translation memory API exposed unintended endpoints, which in turn didn't perform proper access control. This issue has been fixed in version 5.17. If developers are unable to update immediately, they can disable this feature as the CDN add-on is not enabled by default.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free