In short
- CVE-2026-33281 is a HIGH (CVSS 7.5) vulnerability affecting github.com/ellanetworks/core, ella core (ellanetworks).
- Chance of exploitation in the next 30 days (EPSS): 0.41%, higher than 35.2% of all vulnerabilities.
- Fix: update to 1.6.0 or later.
Description
Summary
Ella Core panics when processing NGAP messages with invalid PDU Session IDs outside of 1-15.
Impact
An attacker able to send crafted NGAP messages to Ella Core can crash the process, causing service disruption for all connected subscribers. No authentication is required.
Fix
Added PDU Session ID validations during NGAP message handling.
NVD description
Ella Core is a 5G core designed for private networks. Versions prior to 1.6.0 panic when processing NGAP messages with invalid PDU Session IDs outside of 1-15. An attacker able to send crafted NGAP messages to Ella Core can crash the process, causing service disruption for all connected subscribers. No authentication is required. Version 1.6.0 added PDU Session ID validations during NGAP message handling.
More vulnerabilities in github.com/ellanetworks/core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free