In short
- CVE-2026-33758 is a MEDIUM (CVSS 6.1) vulnerability affecting github.com/openbao/openbao, openbao (openbao).
- Chance of exploitation in the next 30 days (EPSS): 0.30%, higher than 22.5% of all vulnerabilities.
- Fix: update to 0.0.0-20260325133417-6e2b2dd84f0e, 2.5.2 or later.
Description
Impact
OpenBao installations that have an OIDC/JWT authentication method enabled and a role with callback_mode=direct configured are vulnerable to XSS via the error_description parameter on the page for a failed authentication.
This allows an attacker access to the token used in the Web UI by a victim.
Patches
The error_description parameter has been replaced with a static error message in v2.5.2
Workarounds
The vulnerability can be mitigated by removing any roles with callback_mode set to direct.
NVD description
OpenBao is an open source identity-based secrets management system. Prior to version 2.5.2, OpenBao installations that have an OIDC/JWT authentication method enabled and a role with `callback_mode=direct` configured are vulnerable to XSS via the `error_description` parameter on the page for a failed authentication. This allows an attacker access to the token used in the Web UI by a victim. The `error_description` parameter has been replaced with a static error message in v2.5.2. The vulnerability can be mitigated by removing any roles with `callback_mode` set to `direct`.
More vulnerabilities in github.com/openbao/openbao
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free