In short
- CVE-2026-33865 is a MEDIUM (CVSS 5.4) vulnerability affecting mlflow, mlflow (lfprojects).
- Chance of exploitation in the next 30 days (EPSS): 0.22%, higher than 12.3% of all vulnerabilities.
- Fix: update to 3.11.0rc0, 3.11.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.11.0rc0< 3.11.1
| 3.11.0rc03.11.1
|
| mlflow | ≤ 3.10.1
| No fix yet |
Description
MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file containing a payload that executes when another user views the artifact in the UI. This allows actions such as session hijacking or performing operations on behalf of the victim.
This issue affects MLflow version through 3.10.1
NVD description
MLflow is vulnerable to Stored Cross-Site Scripting (XSS) caused by unsafe parsing of YAML-based MLmodel artifacts in its web interface. An authenticated attacker can upload a malicious MLmodel file containing a payload that executes when another user views the artifact in the UI. This allows actions such as session hijacking or performing operations on behalf of the victim.
This issue affects MLflow version through 3.10.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free