In short
- CVE-2026-34052 is a MEDIUM (CVSS 5.9) vulnerability affecting jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 27.7% of all vulnerabilities.
- Fix: update to 1.6.3 or later.
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
More vulnerabilities in jupyterhub-ltiauthenticator
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free