| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.54≥ 11.0.0-M1, < 11.0.21≥ 9.0.40, < 9.0.116 | 10.1.5411.0.219.0.116 |
| org.apache.tomcat:tomcat | ≥ 10.1.0-M1, < 10.1.54≥ 11.0.0-M1, < 11.0.21≥ 9.0.40, < 9.0.116 | 10.1.5411.0.219.0.116 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.54≥ 11.0.0-M1, < 11.0.21≥ 9.0.40, < 9.0.116 | 10.1.5411.0.219.0.116 |
| tomcat | ≥ 10.1.0, < 10.1.54≥ 11.0.0, < 11.0.21≥ 9.0.40, < 9.0.117 | 10.1.5411.0.219.0.117 |
Improper Encoding or Escaping of Output vulnerability in the JsonAccessLogValve component of Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.20, from 10.1.0-M1 through 10.1.53, from 9.0.40 through 9.0.116.
Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117 , which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free