In short
- CVE-2026-34747 is a HIGH (CVSS 8.2) vulnerability affecting payload (payloadcms), payload.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.3% of all vulnerabilities.
- Fix: update to 3.79.1 or later.
| Package | Affected versions | Patched versions |
|---|
| payload | < 3.79.1
| 3.79.1
|
| payload npm | < 3.79.1
| 3.79.1
|
Description
Impact
Certain request inputs were not properly validated. An attacker could craft requests that influence SQL query execution, potentially exposing or modifying data in collections.
Patches
This issue has been fixed in v3.79.1 and later. Query input validation has been hardened.
Upgrade to v3.79.1 or later.
Workarounds
Until developers can upgrade:
- Limit access to endpoints that accept dynamic query inputs to trusted users only.
- Validate or sanitize input from untrusted clients before sending it to query endpoints.
NVD description
Payload is a free and open source headless content management system. Prior to version 3.79.1, certain request inputs were not properly validated. An attacker could craft requests that influence SQL query execution, potentially exposing or modifying data in collections. This issue has been patched in version 3.79.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free