In short
- CVE-2026-34972 is a HIGH (CVSS 8.8) vulnerability affecting github.com/openfga/openfga, helm charts (openfga), openfga (openfga).
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 11.3% of all vulnerabilities.
- Fix: update to 1.14.0, 0.2.62 or later.
Description
Description
In OpenFGA, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement.
Am I affected?
You are affected if you meet the following preconditions:
- You execute BatchCheck operations which rely on context.
- Multiple checks are sent within a single BatchCheck operation for the same user/object/relation combination, each containing context.
- The contexts between those checks differ in a specific way
Fix
Upgrade to OpenFGA v1.14.0
Acknowledgement
OpenFGA would like to thank @bugbunny-research for the discovery and detailed report.
NVD description
OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. From 1.8.0 to 1.13.1, under specific conditions, BatchCheck calls with multiple checks sent for the same object, relation, and user combination can result in improper policy enforcement. This vulnerability is fixed in 1.14.0.
More vulnerabilities in github.com/openfga/openfga
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free