In short
- CVE-2026-35646 is a MEDIUM (CVSS 6.5) vulnerability affecting openclaw (openclaw), openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.7% of all vulnerabilities.
- Fix: update to 2026.3.25, 2026.3.28 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.3.25
| 2026.3.25
|
| openclaw npm | < 2026.3.28
| 2026.3.28
|
Description
Summary
Synology Chat Webhook Pre-Auth Rate-Limit Bypass Enables Brute-Force Guessing of Weak Webhook Token
Affected Packages / Versions
- Package:
openclaw
- Affected versions:
<= 2026.3.24
- First patched version:
2026.3.25
- Latest published npm version at verification time:
2026.3.24
Details
Synology Chat webhook auth previously rejected invalid tokens without throttling repeated guesses, allowing brute-force attempts against weak webhook secrets. Commit 0b4d07337467f4d40a0cc1ced83d45ceaec0863c adds repeated-guess throttling before auth failure responses.
Verified vulnerable on tag v2026.3.24 and fixed on main by commit 0b4d07337467f4d40a0cc1ced83d45ceaec0863c.
Fix Commit(s)
0b4d07337467f4d40a0cc1ced83d45ceaec0863c
NVD description
OpenClaw before 2026.3.25 contains a pre-authentication rate-limit bypass vulnerability in webhook token validation that allows attackers to brute-force weak webhook secrets. The vulnerability exists because invalid webhook tokens are rejected without throttling repeated authentication attempts, enabling attackers to guess weak tokens through rapid successive requests.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free