In short
- CVE-2026-3590 is a MEDIUM (CVSS 6.5) vulnerability affecting github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5, github.com/mattermost/mattermost-server/v6.
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 4.3% of all vulnerabilities.
- Fix: update to 10.11.13, 10.11.13+incompatible, 11.3.3, 11.3.3+incompatible or later.
Description
Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to enforce atomic single-use consumption of guest magic link tokens, which allows an attacker with access to a valid magic link to establish multiple independent authenticated sessions via concurrent requests. Mattermost Advisory ID: MMSA-2026-00624.
NVD description
Mattermost versions 10.11.x <= 10.11.12, 11.5.x <= 11.5.0, 11.4.x <= 11.4.2, 11.3.x <= 11.3.2 fail to enforce atomic single-use consumption of guest magic link tokens, which allows an attacker with access to a valid magic link to establish multiple independent authenticated sessions via concurrent requests.. Mattermost Advisory ID: MMSA-2026-00624
More vulnerabilities in github.com/mattermost/mattermost-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free