In short
- CVE-2026-37461 is a HIGH (CVSS 7.5) vulnerability affecting github.com/osrg/gobgp/v4, gobgp (osrg).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 26.9% of all vulnerabilities.
- Fix: update to 4.4.0 or later.
Description
An out-of-bounds read in the ParseIP6Extended function (/bgp/bgp.go) of gobgp v4.3.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted BGP UPDATE message.
NVD description
An out-of-bounds read in the ParseIP6Extended function (/bgp/bgp.go) of gobgp v4.3.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted BGP UPDATE message.
More vulnerabilities in github.com/osrg/gobgp/v4
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free