| Package | Affected versions | Patched versions |
|---|---|---|
| github.com/m1k1o/neko/server | ≥ 0.0.0-20250322225643-212bf8a60756, < 0.0.0-20260406184107-c54bcf1ee211≥ 0.0.0-20250326225119-51bbad7650d3, < 0.0.0-20260406184107-c54bcf1ee211≥ 3.0.0, < 3.0.11 | 0.0.0-20260406184107-c54bcf1ee2113.0.11 |
| neko | ≥ 3.0.0, < 3.0.11≥ 3.1.0, < 3.1.2 | 3.0.113.1.2 |
Any authenticated user can immediately obtain full administrative control of the entire Neko instance (member management, room settings, broadcast control, session termination, etc.). This results in a complete compromise of the instance.
The vulnerability has been patched in the following releases:
Users should upgrade to v3.0.11 or later (for the 3.0 branch) or v3.1.2 or later.
If upgrading is not immediately possible, the following mitigations can reduce risk:
/api/profile endpoint if feasibleNote: These are temporary mitigations and do not fully eliminate the vulnerability. Upgrading is strongly recommended.
Neko thanks @blitzkrieg-patch for responsibly disclosing this vulnerability and reaching out directly. This contribution helped strengthen the project, and the whole community benefits from it.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free