In short
- CVE-2026-40091 is a MEDIUM (CVSS 4.4) vulnerability affecting github.com/authzed/spicedb, spicedb (authzed).
- Chance of exploitation in the next 30 days (EPSS): 0.17%, higher than 5.9% of all vulnerabilities.
- Fix: update to 1.51.1 or later.
Description
Impact
When SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI.
Patches
v1.51.1
Workarounds
Change the log level to warn or error.
NVD description
SpiceDB is an open source database system for creating and managing security-critical application permissions. In versions 1.49.0 through 1.51.0, when SpiceDB starts with log level info, the startup "configuration" log will include the full datastore DSN, including the plaintext password, inside DatastoreConfig.URI. This issue has been fixed in version 1.51.1. If users are unable to immediately upgrade, they can work around this issue by changing the log level to warn or error.
More vulnerabilities in github.com/authzed/spicedb
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free