In short
- CVE-2026-40256 is a MEDIUM (CVSS 5.0) vulnerability affecting weblate, weblate (weblate).
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.5% of all vulnerabilities.
- Fix: update to 5.17 or later.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
Weblate repository-boundary validation relies on string prefix checks on resolved absolute paths. In multiple code paths, the check uses startswith against the repository root path. This is not path-segment aware and can be bypassed when the external path shares the same string prefix as the repository path (for example, repo and repo_outside).
Patches
References
Thanks to m9nx4u for reporting this issue via HackerOne.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, repository-boundary validation relies on string prefix checks on resolved absolute paths. In multiple code paths, the check uses startswith against the repository root path. This is not path-segment aware and can be bypassed when the external path shares the same string prefix as the repository path (for example, repo and repo_outside). This issue has been fixed in version 5.17.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free