| Package | Affected versions | Patched versions |
|---|---|---|
| pac4j | ≥ 4.0.0, < 4.5.10≥ 5.0.0, < 5.7.10≥ 6.0.0, < 6.4.1 | 4.5.105.7.106.4.1 |
PAC4J is vulnerable to LDAP Injection in multiple methods. A low-privileged remote attacker can inject crafted LDAP syntax into ID-based search parameters, potentially resulting in unauthorized LDAP queries and arbitrary directory operations. This issue was fixed in PAC4J versions 4.5.10, 5.7.10 and 6.4.1
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free