In short
- CVE-2026-41313 is a MEDIUM (CVSS 6.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 11.8% of all vulnerabilities.
- Fix: update to 6.10.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.10.2
| 6.10.2
|
| pypdf | < 6.10.2
| 6.10.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires loading a PDF with a large trailer /Size value in incremental mode.
Patches
This has been fixed in pypdf==6.10.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3735.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions prior to 6.10.2 can craft a PDF which leads to long runtimes. This requires loading a PDF with a large trailer `/Size` value in incremental mode. This has been fixed in pypdf 6.10.2. As a workaround, one may apply the changes from the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free