In short
- CVE-2026-41359 is a HIGH (CVSS 8.8) vulnerability affecting openclaw (openclaw), openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.23%, higher than 14.1% of all vulnerabilities.
- Fix: update to 2026.3.28 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.3.28
| 2026.3.28
|
| openclaw npm | < 2026.3.28
| 2026.3.28
|
Description
Summary
Gateway operator.write Can Reach Admin-Class Telegram Config and Cron Persistence via send
Current Maintainer Triage
- Status: narrow
- Normalized severity: medium
- Assessment: Real shipped operator.write to admin-class Telegram config or cron persistence bug, but it is an authenticated sink-specific escalation and high is too high given the narrower scope.
Affected Packages / Versions
- Package:
openclaw (npm)
- Latest published npm version:
2026.3.31
- Vulnerable version range:
<=2026.3.24
- Patched versions:
>= 2026.3.28
- First stable tag containing the fix:
v2026.3.28
Fix Commit(s)
b7d70ade3b9900dbe97bd73be9c02e924ff3c986 — 2026-03-25T12:12:09-06:00
Release Process Note
- The fix is already present in released version
2026.3.28.
- This draft looks ready for final maintainer disposition or publication, not additional code-fix work.
Thanks @zpbrent for reporting.
NVD description
OpenClaw before 2026.3.28 contains a privilege escalation vulnerability allowing authenticated operators with write permissions to access admin-class Telegram configuration and cron persistence settings via the send endpoint. Attackers with operator.write credentials can exploit insufficient access controls to reach sensitive administrative functionality and modify persistence mechanisms.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free