In short
- CVE-2026-41369 is a MEDIUM (CVSS 6.5) vulnerability affecting openclaw (openclaw), openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.31%, higher than 23.5% of all vulnerabilities.
- Fix: update to 2026.3.31 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.3.31
| 2026.3.31
|
| openclaw npm | < 2026.3.31
| 2026.3.31
|
Description
Summary
Host exec environment sanitization misses package, registry, Docker, compiler, and TLS override variables
Current Maintainer Triage
- Normalized severity: medium
- Assessment: v2026.3.28 also misses the broader package, registry, compiler, Docker, and TLS env family in the shipped host-env policy, and the unreleased main fix means this is a real medium-severity open issue.
Affected Packages / Versions
- Package:
openclaw (npm)
- Latest published npm version:
2026.3.31
- Vulnerable version range:
<=2026.3.28
- Patched versions:
>= 2026.3.31
- First stable tag containing the fix:
v2026.3.31
Fix Commit(s)
eb8de6715f02949c21c4e895fffc8a6dcb00975c — 2026-03-31T19:37:43+09:00
OpenClaw thanks @tdjackey for reporting.
NVD description
OpenClaw before 2026.3.31 contains insufficient environment variable sanitization in host exec operations, failing to filter package, registry, Docker, compiler, and TLS override variables. Attackers can exploit this by injecting malicious environment variables to override critical system configurations and compromise host execution integrity.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free