In short
- CVE-2026-41379 is a HIGH (CVSS 7.1) vulnerability affecting openclaw (openclaw), openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.24%, higher than 15.6% of all vulnerabilities.
- Fix: update to 2026.3.28 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | < 2026.3.28
| 2026.3.28
|
| openclaw npm | < 2026.3.28
| 2026.3.28
|
Description
Summary
Gateway operator.write Can Reach Admin-Class Talk Voice Config Persistence via chat.send
Current Maintainer Triage
- Status: narrow
- Normalized severity: medium
- Assessment: Real shipped operator.write to admin-class Talk Voice config persistence bug, but it is the same narrow authenticated persistence class and should be normalized below high.
Affected Packages / Versions
- Package:
openclaw (npm)
- Latest published npm version:
2026.3.31
- Vulnerable version range:
<=2026.3.24
- Patched versions:
>= 2026.3.28
- First stable tag containing the fix:
v2026.3.28
Fix Commit(s)
e34694733fc64931ed4a543c73d84ad3435d5df1 — 2026-03-25T19:55:26Z
Release Process Note
- The fix is already present in released version
2026.3.28.
- This draft looks ready for final maintainer disposition or publication, not additional code-fix work.
Thanks @zpbrent for reporting.
NVD description
OpenClaw before 2026.3.28 contains a privilege escalation vulnerability allowing authenticated operators with write permissions to access admin-class Talk Voice configuration persistence. Attackers with operator.write privileges can exploit the chat.send endpoint to reach and modify sensitive voice configuration settings intended for administrators only.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free