| Package | Affected versions | Patched versions |
|---|---|---|
| org.springframework.ai:spring-ai-milvus-store | ≥ 1.0.0, < 1.0.7≥ 1.1.0, < 1.1.6 | 1.0.71.1.6 |
| org.springframework.ai:spring-ai-typesense-store | ≥ 1.0.0, < 1.0.7≥ 1.1.0, < 1.1.6 | 1.0.71.1.6 |
| spring ai | ≥ 1.0.0, < 1.0.7≥ 1.1.0, < 1.1.6 | 1.0.71.1.6 |
Spring AI's MilvusVectorStore#doDelete(List) implementation is vulnerable to filter-expression injection via unsanitized document IDs. Spring AI 1.0.x: affected from 1.0.0 through latest 1.0.x; upgrade to 1.0.7 or greater. Spring AI 1.1.x: affected from 1.1.0 through latest 1.1.x; upgrade to 1.1.6 or greater.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free