| Package | Affected versions | Patched versions |
|---|---|---|
| perl | ≥ 5.41.0, < 5.42.2≥ 5.43.0, < 5.43.9≥ 5.9.4, < 5.40.4 | 5.42.25.43.95.40.4 |
Perl versions from 5.9.4 before 5.40.4-RC1, from 5.41.0 before 5.42.2-RC1, from 5.43.0 before 5.43.9 contain a vulnerable version of Compress::Raw::Zlib. Compress::Raw::Zlib is included in the Perl package as a dual-life core module, and is vulnerable to CVE-2026-3381 due to a vendored version of zlib which has several vulnerabilities, including CVE-2026-27171. The bundled Compress::Raw::Zlib was updated to version 2.221 in Perl blead commit c75ae9cc164205e1b6d6dbd57bd2c65c8593fe94.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free