In short
- CVE-2026-42509 is a MEDIUM (CVSS 6.1) vulnerability affecting org.apache.wicket:wicket-parent, wicket (apache).
- Chance of exploitation in the next 30 days (EPSS): 0.36%, higher than 29.4% of all vulnerabilities.
- Fix: update to 10.9.0 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket-parent Maven | ≥ 10.0.0-M1, < 10.9.0≥ 8.0.0-M1, ≤ 8.17.0≥ 9.0.0-M1, ≤ 9.22.0
| 10.9.0
|
| wicket | ≥ 10.0.0, < 10.9.0≥ 8.0.0, ≤ 8.17.0≥ 9.0.0, ≤ 9.22.0
| 10.9.0
|
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
NVD description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
More vulnerabilities in org.apache.wicket:wicket-parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free