In short
- CVE-2026-42615 is a HIGH (CVSS 7.2) vulnerability affecting cyberchef.
- Chance of exploitation in the next 30 days (EPSS): 0.29%, higher than 22.2% of all vulnerabilities.
- Fix: update to 11.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| cyberchef npm | < 11.0.0
| 11.0.0
|
Description
GCHQ CyberChef before 11.0.0 allows XSS via Show Base64 offsets, as demonstrated by the /#recipe=Show_Base64_offsets('%3Cscript substring.
NVD description
GCHQ CyberChef before 11.0.0 allows XSS via Show Base64 offsets, as demonstrated by the /#recipe=Show_Base64_offsets('%3Cscript substring.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free