| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat.embed:tomcat-embed-core | ≥ 10.1.0-M1, < 10.1.55≥ 11.0.0-M1, < 11.0.22< 9.0.118 | 10.1.5511.0.229.0.118 |
| org.apache.tomcat:tomcat | ≥ 10.1.0-M1, < 10.1.55≥ 11.0.0-M1, < 11.0.22< 9.0.118 | 10.1.5511.0.229.0.118 |
| org.apache.tomcat:tomcat-catalina | ≥ 10.1.0-M1, < 10.1.55≥ 11.0.0-M1, < 11.0.22< 9.0.118 | 10.1.5511.0.229.0.118 |
| tomcat | ≥ 10.1.0, < 10.1.55≥ 11.0.0, < 11.0.22≥ 7.0.0, ≤ 7.0.109≥ 8.5.0, ≤ 8.5.100≥ 9.0.0, < 9.0.118 | 10.1.5511.0.229.0.118 |
Improper Handling of Case Sensitivity vulnerability in LockOutRealm in Apache Tomcat.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.21, from 10.1.0-M1 through 10.1.54, from 9.0.0.M1 through 9.0.117, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Older unsupported versions may also be affected.
Users are recommended to upgrade to version 11.0.22, 10.1.55 or 9.0.118 which fix the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free