In short
- CVE-2026-43570 is a MEDIUM (CVSS 6.5) vulnerability affecting openclaw (openclaw), openclaw.
- Chance of exploitation in the next 30 days (EPSS): 0.32%, higher than 25.4% of all vulnerabilities.
- Fix: update to 2026.4.5 or later.
| Package | Affected versions | Patched versions |
|---|
| openclaw | ≥ 2026.3.22, < 2026.4.5
| 2026.4.5
|
| openclaw npm | ≥ 2026.3.22, < 2026.4.5
| 2026.4.5
|
Description
OpenClaw versions 2026.3.22 before 2026.4.5 contain a symlink traversal vulnerability in remote marketplace repository path handling that allows attackers to escape the expected repository root. Attackers can exploit this by providing crafted symlink paths to access files outside the intended repository directory.
NVD description
OpenClaw versions 2026.3.22 before 2026.4.5 contain a symlink traversal vulnerability in remote marketplace repository path handling that allows attackers to escape the expected repository root. Attackers can exploit this by providing crafted symlink paths to access files outside the intended repository directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free