In short
- CVE-2026-44022 is a MEDIUM (CVSS 5.5) vulnerability affecting docling, docling (docling).
- Chance of exploitation in the next 30 days (EPSS): 0.21%, higher than 10.8% of all vulnerabilities.
- Fix: update to 2.91.0 or later.
| Package | Affected versions | Patched versions |
|---|
| docling PyPI | ≥ 2.73.0, < 2.91.0
| 2.91.0
|
| docling | ≥ 2.73.0, < 2.91.0
| 2.91.0
|
Description
Impact
The LaTeX backend's handling of \includegraphics, \input, and \include commands lacked path containment validation. Attackers could craft malicious LaTeX documents with path traversal sequences (e.g., ../../../etc/passwd) to:
- Read arbitrary files from the file system accessible to the process
- Include sensitive files in the converted document output
- Potentially access configuration files, credentials, or other sensitive data
Patches
Fixed in version 2.91.0. The fix implements strict path validation using Path.resolve().is_relative_to() to ensure all resolved paths remain within the base document directory. Attempts to traverse outside the base directory are logged and blocked.
Workarounds
Avoid processing untrusted LaTeX documents. If processing is necessary, run in a sandboxed environment with restricted file system access.
References
NVD description
Docling simplifies document processing by parsing diverse formats and providing integrations with the generative AI ecosystem. From 2.73.0 until 2.91.0, he LaTeX backend's handling of \includegraphics, \input, and \include commands lacked path containment validation. Attackers could craft malicious LaTeX documents with path traversal sequences to read arbitrary files from the file system accessible to the process, include sensitive files in the converted document output, or potentially access configuration files, credentials, or other sensitive data This vulnerability is fixed in 2.91.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free