In short
- CVE-2026-44203 is a HIGH (CVSS 8.3) vulnerability affecting org.openidentityplatform.openam:openam-oauth2.
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.4% of all vulnerabilities.
- Fix: update to 16.1.1 or later.
Description
Summary
The OAuth 2.0 / OpenID Connect authorization endpoint does not sufficiently sanitize certain user-supplied parameters before incorporating them into the HTML response generated for the form_post response mode. This may allow an attacker to inject content into the rendered page in the context of the OpenAM origin.
NVD description
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the OAuth 2.0 and OpenID Connect authorization endpoint does not sufficiently encode user-supplied parameters before FormPostResponse.ftl and checkSession.ftl render them into HTML for the form_post response mode. An unauthenticated attacker can induce a user to open a crafted authorization request and execute script in the OpenAM origin. This issue is fixed in version 16.1.1.
More vulnerabilities in org.openidentityplatform.openam:openam-oauth2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free