In short
- CVE-2026-44793 is a HIGH (CVSS 7.0) vulnerability affecting org.openidentityplatform.openam:openam-federation-library.
- Chance of exploitation in the next 30 days (EPSS): 0.59%, higher than 48.4% of all vulnerabilities.
- Fix: update to 16.1.1 or later.
Description
Summary
Certain federation endpoints do not consistently apply output encoding when rendering user-supplied parameters into HTML responses. Under a non-default configuration used in some clustered deployments, this inconsistency can result in reflected XSS in the OpenAM origin without authentication.
NVD description
Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, certain federation endpoints in a non-default clustered configuration inconsistently encode user-supplied parameters rendered into HTML in the SAML2 cluster cookie-hash redirect path. An unauthenticated attacker can induce a user to follow a crafted request and execute script in the OpenAM origin. This issue is fixed in version 16.1.1.
More vulnerabilities in org.openidentityplatform.openam:openam-federation-library
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free