In short
- CVE-2026-44795 is a HIGH (CVSS 8.8) vulnerability affecting io.spinnaker.orca:orca-core, io.spinnaker.rosco:rosco-core, spinnaker (linuxfoundation).
- Chance of exploitation in the next 30 days (EPSS): 1.0%, higher than 63.2% of all vulnerabilities.
- Fix: update to 2025.4.4, 2026.0.3, 2025.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| io.spinnaker.orca:orca-core Maven | ≥ 2025.4.0, < 2025.4.4≥ 2026.0.0, < 2026.0.3< 2025.3.3
| 2025.4.42026.0.32025.3.3
|
| io.spinnaker.rosco:rosco-core Maven | ≥ 2025.4.0, < 2025.4.4≥ 2026.0.0, < 2026.0.3< 2025.3.3
| 2025.4.42026.0.32025.3.3
|
| spinnaker | ≥ 2025.4.0, < 2025.4.4≥ 2026.0.0, < 2026.0.3< 2025.3.3
| 2025.4.42026.0.32025.3.3
|
Description
Impact
There's an unsafe YAML processing vulnerability that bypasses safe deserialization. This impacts users when when performing:
- CloudFormation deployments
- CloudFoundry Baking
The usage of a non-safe constructor use allows arbitrary loading of Java classes leading to RCE.
Patches
2025.3.3, 2026.0.3 and 2025.4.4.
Workarounds
Disable the CloudFormation system and cloudfoundry baking operations.
Resources
Join Spinnaker on Slack for more information!
NVD description
Spinnaker is an open source, multi-cloud continuous delivery platform. Prior to 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3, unsafe YAML processing bypasses safe deserialization when using CloudFormation deployments or CloudFoundry baking. The use of a non-safe constructor allows arbitrary loading of Java classes, leading to remote code execution. This issue is fixed in versions 2026.1.0, 2026.0.3, 2025.4.4, and 2025.3.3.
More vulnerabilities in io.spinnaker.orca:orca-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free