In short
- CVE-2026-45660 is a MEDIUM (CVSS 5.4) vulnerability affecting statamic/cms.
- Chance of exploitation in the next 30 days (EPSS): 0.15%, higher than 4.3% of all vulnerabilities.
- Fix: update to 6.18.1, 5.73.22 or later.
| Package | Affected versions | Patched versions |
|---|
| statamic/cms Packagist | ≥ 6.0.0-alpha.1, < 6.18.1< 5.73.22
| 6.18.15.73.22
|
Description
Impact
The Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints.
This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected.
Patches
This has been fixed in 5.73.22 and 6.18.1
NVD description
Statamic is a Laravel and Git powered content management system (CMS). Prior to 5.73.22 and 6.18.1, the Glide image proxy's URL validation could be bypassed using an IP representation that wasn't normalized before the public-IP check. An unauthenticated user could cause the server to make HTTP requests to internal addresses — including loopback, private network, and cloud metadata endpoints. This affects sites that pass user-supplied URLs to Glide. Sites running PHP 8.3 or newer are not affected. This vulnerability is fixed in 5.73.22 and 6.18.1.
More vulnerabilities in statamic/cms
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free