| Package | Affected versions | Patched versions |
|---|---|---|
| discourse | = 2026.6.0≥ 2026.1.0, < 2026.1.5≥ 2026.4.0, < 2026.4.2≥ 2026.5.0, < 2026.5.1 | 2026.1.52026.4.22026.5.1 |
Discourse is an open-source discussion platform. Prior to 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5, secure uploads could be exposed by pull_hotlinked_images when an attacker knew the secured upload URL and the secure_uploads site setting was enabled. This issue is fixed in versions 2026.6.0, 2026.5.1, 2026.4.2, and 2026.1.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free