In short
- CVE-2026-45808 is a HIGH (CVSS 7.1) vulnerability affecting github.com/openbao/openbao.
- Chance of exploitation in the next 30 days (EPSS): 0.43%, higher than 37.0% of all vulnerabilities.
- Fix: update to 2.5.4 or later.
Description
Impact
OpenBao's namespaces provide multi-tenant separation. A tenant who intentionally leaks lease identifiers can have their lease and underlying credential revoked or renewed by a user in another tenant via the legacy, undocumented sys/revoke and sys/renew endpoints.
Patch
This will be addressed in v2.5.4.
NVD description
OpenBao is an open source identity-based secrets management system. Prior to version 2.5.4, OpenBao's namespaces provide multi-tenant separation. A tenant who intentionally leaks lease identifiers can have their lease and underlying credential revoked or renewed by a user in another tenant via the legacy, undocumented `sys/revoke` and `sys/renew` endpoints. This is fixed in OpenBao v2.5.4.
More vulnerabilities in github.com/openbao/openbao
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free