In short
- CVE-2026-45822 is a MEDIUM (CVSS 6.6) vulnerability affecting decode-uri-component.
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.3% of all vulnerabilities.
- Fix: update to 0.5.0 or later.
Description
Impact
An attacker who can supply input to decodeUriComponent() (directly or via a dependency that uses this package on URL/query/path data) can cause excessive CPU usage and application unresponsiveness. This is an availability issue; there is no known memory corruption, data disclosure, or remote code execution impact.
Patches
Upgrade to [email protected].
Workarounds
Limit the size of the input.
NVD description
decode-uri-component through 0.4.1 is vulnerable to denial of service. The decode() function splits input on '%' producing N tokens and calls decodeComponents(), exhibiting super-linear parsing time: 200 '%ab' tokens takes approximately 0.7s, 700 tokens approximately 6s, and 1400 tokens approximately 33s. An attacker can cause significant CPU consumption and event-loop blocking via crafted input.
More vulnerabilities in decode-uri-component
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free