In short
- CVE-2026-47101 is a HIGH (CVSS 8.8) vulnerability affecting litellm, litellm (litellm).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.8% of all vulnerabilities.
- Fix: update to 1.83.14 or later.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.83.14
| 1.83.14
|
| litellm | < 1.83.14
| 1.83.14
|
Description
LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit. When generating a key, the allowed_routes field is stored without verifying that the specified routes fall within the user's own permissions. A key created with access to admin-only routes can then be used to reach those routes successfully, bypassing the role-based access controls that would otherwise block the request, enabling full privilege escalation from internal_user to proxy_admin.
NVD description
LiteLLM prior to 1.83.14 allows an authenticated internal_user to create API keys with access to routes that their role does not permit. When generating a key, the allowed_routes field is stored without verifying that the specified routes fall within the user's own permissions. A key created with access to admin-only routes can then be used to reach those routes successfully, bypassing the role-based access controls that would otherwise block the request, enabling full privilege escalation from internal_user to proxy_admin.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free