In short
- CVE-2026-47104 is a MEDIUM (CVSS 5.5) vulnerability affecting libusb, libusb (libusb).
- Chance of exploitation in the next 30 days (EPSS): 0.13%, higher than 2.7% of all vulnerabilities.
- Fix: update to 1.0.30 or later.
| Package | Affected versions | Patched versions |
|---|
| libusb PyPI | < 1.0.30
| 1.0.30
|
| libusb | < 1.0.30
| 1.0.30
|
Description
libusb before version 1.0.30 contains a one-byte out-of-bounds read vulnerability in parse_iad_array() in descriptor.c that allows attackers to trigger a denial of service by supplying a malformed USB descriptor whose bLength equals size minus one, causing the bounds check to use the original buffer size instead of the remaining size. Attackers in virtualized environments with USB passthrough can supply crafted descriptors through libusb_get_active_interface_association_descriptors or libusb_get_interface_association_descriptors to read one byte past the end of the malloc allocation, resulting in a denial of service.
NVD description
libusb before version 1.0.30 contains a one-byte out-of-bounds read vulnerability in parse_iad_array() in descriptor.c that allows attackers to trigger a denial of service by supplying a malformed USB descriptor whose bLength equals size minus one, causing the bounds check to use the original buffer size instead of the remaining size. Attackers in virtualized environments with USB passthrough can supply crafted descriptors through libusb_get_active_interface_association_descriptors or libusb_get_interface_association_descriptors to read one byte past the end of the malloc allocation, resulting in a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free