In short
- CVE-2026-48156 is a LOW (CVSS 3.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.12%, higher than 2.1% of all vulnerabilities.
- Fix: update to 6.12.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.0
| 6.12.0
|
| pypdf | < 6.12.0
| 6.12.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W [0 0 0] values and large /Size values.
Patches
This has been fixed in pypdf==6.12.0.
Workarounds
If developers are unable to upgrade their apps immediately, they should consider applying the changes from PR #3791.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.0, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires cross-reference streams with /W [0 0 0] values and large /Size values. This vulnerability is fixed in 6.12.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free