In short
- CVE-2026-49014 is a HIGH (CVSS 7.8) vulnerability affecting gdal, gdal (osgeo).
- Chance of exploitation in the next 30 days (EPSS): 0.10%, higher than 0.92% of all vulnerabilities.
- Fix: update to 3.13.1 or later.
| Package | Affected versions | Patched versions |
|---|
| gdal PyPI | ≥ 3.1.0, < 3.13.1
| 3.13.1
|
| gdal | ≥ 3.1.0, ≤ 3.13.0
| No fix yet |
Description
In GDAL 3.1.0 through 3.13.0, scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow. It reads a geometry attribute into a fixed-size stack buffer without validating the attribute length. The attacker embeds the exploit as an oversized geometry attribute in a crafted NetCDF file. This achieves arbitrary code execution on the server running GDAL. This is in frmts/netcdf/netcdfsg.cpp.
NVD description
In GDAL 3.1.0 through 3.13.0, scanForGeometryContainers in the netCDF driver allows code execution via a stack-based buffer overflow. It reads a geometry attribute into a fixed-size stack buffer without validating the attribute length. The attacker embeds the exploit as an oversized geometry attribute in a crafted NetCDF file. This achieves arbitrary code execution on the server running GDAL. This is in frmts/netcdf/netcdfsg.cpp.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free