In short
- CVE-2026-49119 is a HIGH (CVSS 7.5) vulnerability affecting gradio, gradio (gradio project).
- Chance of exploitation in the next 30 days (EPSS): 0.69%, higher than 52.8% of all vulnerabilities.
- Fix: update to 6.16.0 or later.
| Package | Affected versions | Patched versions |
|---|
| gradio PyPI | < 6.16.0
| 6.16.0
|
| gradio | < 6.16.0
| 6.16.0
|
Description
Gradio before 6.16.0 contain a path traversal vulnerability in the FileExplorer component's preprocess() method that allows unauthenticated attackers to escape the configured root directory by supplying path segments containing directory traversal sequences or absolute paths. Attackers can provide crafted path segments that cause os.path.join to discard the root_dir prefix entirely, resulting in arbitrary file read or exposure of sensitive files outside the intended directory.
NVD description
Gradio before 6.16.0 contain a path traversal vulnerability in the FileExplorer component's preprocess() method that allows unauthenticated attackers to escape the configured root directory by supplying path segments containing directory traversal sequences or absolute paths. Attackers can provide crafted path segments that cause os.path.join to discard the root_dir prefix entirely, resulting in arbitrary file read or exposure of sensitive files outside the intended directory.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free