In short
- CVE-2026-49460 is a LOW (CVSS 3.3) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.17%, higher than 5.8% of all vulnerabilities.
- Fix: update to 6.12.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.2
| 6.12.2
|
| pypdf | < 6.12.2
| 6.12.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /FlateDecode filter with a PNG predictor.
Patches
This has been fixed in pypdf==6.12.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3806.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.2, an attacker who uses this vulnerability can craft a PDF which leads to long runtimes. This requires accessing a stream which uses the /FlateDecode filter with a PNG predictor. This vulnerability is fixed in 6.12.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free