In short
- CVE-2026-49461 is a MEDIUM (CVSS 5.5) vulnerability affecting pypdf, pypdf (pypdf project).
- Chance of exploitation in the next 30 days (EPSS): 0.17%, higher than 6.9% of all vulnerabilities.
- Fix: update to 6.12.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.12.2
| 6.12.2
|
| pypdf | < 6.12.2
| 6.12.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting the text of a page which contains a form XObject with self-references.
Patches
This has been fixed in pypdf==6.12.2.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3805.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.12.2, an attacker who uses this vulnerability can craft a PDF which leads to large memory usage. This requires extracting the text of a page which contains a form XObject with self-references. This vulnerability is fixed in 6.12.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free